Last checked:

How do I install and register Avira Antivirus Security Pro for Android?

info-symbol
The Avira Antivirus Security app is suitable for use on most Android Smartphones, tablets and phablets. Unsupported telephony function in tablets will be automatically deactivated in the app.

grey-line
Note
Avira Antivirus Security for Android works on a multi-user device only if you are logged in as primary user.
grey-line

settings-icon
Install and register
  1. Go to Google Play and install the app.
  2. Once the installation is complete, open the app.
  3. A brief overview of the included functions is displayed. Tap Skip.

    avira-antivirus-for-android_first-screen-after-installation_antivirus_en

  4. Tap the menu drawer icon menu_drawer_icon in the upper left corner.

    avira-antivirus-for-android_after-clicking-skip_en

  5. Tap Account → Register with an email address.

    avira-antivirus-for-android_after-taping-configuration_en     avira-antivirus-for-android_after-taping-configuration_register_en

  6. Enter your email address and password and tap Log in.

    avira-antivirus-for-android_after-taping-configuration_register_enter-email-and-password_en

  7. Once registered the app is displayed as “Antivirus Security Pro”.

    avira-antivirus-for-android_after-registerin-pro-version_en

  8. Tap Perform your first scan.

    avira-antivirus-for-android_perform-your-first-scan_en

Comments

It's hard to believe I am the first user to add a comment about this article. The installation was easy enough (I guess), but I am not able to find any "Getting Started" button or tutorial of any kind on this website that tells me how to use all the features of this product. If I go to www.My.Avira.com, that address apparently doesn't even exist. When I open the account I set up, there is just a scarce amount of info about me, and no way to navigate to my other devices. There is no "Web Console" to be found. I am very close to deleting this app and installing the Consumer Reports highly recommended Avast Free Android app.

Bought Android smartphone and trying to associate the device with my current license (Avira Antivirus Pro - Business Edition 36 months / 3 devices). Activation using SMS or email from desktop failed - not delivered to the phone. I downloaded the free version from Google play, then tried to enter the activation code using web dashboard. The app indicated invalid activation code so I tried 'Restore purchases'. Got a message 'no license associated to this email'. In the web dashboard I can see the newly added device while the app still offers 'Get Pro'.
What could be wrong?

Add new comment

Your report was successfully sent.
There was an error! Please, try again later!